Patterns are a great way to turn your projects up to eleven and make any composition rock. Check out these steps to implement them in your projects.

Using Patterns in Photoshop

There are two ways to use patterns in photoshop: Fill and as a Paint Brush. Let's cover how to fill an area first.

How to fill with a pattern in Photoshop:

  1. Open an image you want to use as a pattern base.

    Photoshop with an image of flowers in a field.
  2. Use the Rectangle Marquee tool to select an area to use as a pattern.

    Photoshop with rectangular marquee tool and a selection highlighted in image of flowers

    If you want to use the entire image as your fill, go to Select > Select All.

  3. Select Edit > Define Pattern.

    Define Pattern highlighted in Photoshop with image of flowers
  4. In the Define Pattern dialog box, name the pattern and select OK.

    Photoshop Define Pattern dialog with Flower pattern and OK highlighted
  1. Open or create another image.

    Field image open in Photoshop
  2. Select the layer you want to fill, or make a selection using the Rectangular Marquee or another selection tool.

    Photoshop image of a field with selected area highlighted
  3. Go to Edit > Fill.

    Fill selected from Photoshop's Edit menu
  4. Select Pattern.

    Pattern selected in Photoshop's Fill dialog
  5. Next to Custom Pattern, select the down-arrow.

    Down arrow highlighted next to Select Pattern in Photoshop Fill dialog
  6. Select your new custom pattern.

    New custom pattern highlighted in Photoshop Edit Fill dialog
  7. Leave the Script checkbox deselected. (Scripted patterns are JavaScripts that randomly place an item defined as a pattern either in the selection or on a layer.)

    Unselected Script box highlighted in Photoshop Edit Fill dialog
  8. Choose a Blending Mode to have your pattern interact with the colors of the pixels of the image it is placed over, especially if it is on a separate layer. Select OK.

    Blending modes and OK highlighted in Photoshop Edit Fill dialog
  9. View your result. Add additional fills as needed to create your vision.

    New image with pattern shown in Photoshop

And that's it! Photoshop will replicate the pattern to fill any area you define.

How to use a Pattern as a Paintbrush:

The Pattern Stamp tool paints with a pattern. You can select a pattern from the pattern libraries or create your own patterns.

  1. Select the Pattern Stamp tool .

  2. Choose a brush from the Brush Presets panel. See Select a preset brush.

  3. Set tool options for mode, opacity, etc. in the options bar. See Paint tool options.

  4. Select Aligned in the options bar to maintain the pattern’s continuity with your original start point, even if you release the mouse button and then continue painting. Deselect Aligned to restart the pattern each time you stop and start painting.

  5. Select a pattern from the Pattern pop‑up panel in the options bar.

  6. If you’d like to apply the pattern with an impressionistic effect, select Impressionist.

  7. Drag in the image to paint it with the pattern.

How To Use Patterns in Illustrator:

Create a pattern

Start by selecting an artwork to be used for the pattern and choose Object > Pattern > Make. This will open Pattern Editing Mode.

Editing pattern options

In Pattern Editing mode, a blue pattern tile (box) surrounds the artwork. Anything within the bounds of the pattern tile, by default, is repeated to create the pattern. You can add, remove, or edit the artwork in the pattern tile.

In the Pattern Options panel, you can do the following:

  • Name the pattern.

  • Choose a Tile Type, or how the pattern repeats.

  • Size the pattern tile to the artwork.

  • Change the Width and Height of the pattern tile.

  • Set how the artwork overlaps, and more.

  • How to create and edit patterns in Illustrator

When finished editing the pattern options and the artwork, click Done in the gray bar at the top of the document window to save the pattern changes.

Apply the pattern swatch to artwork

You can apply the pattern you created to the fill or stroke of artwork.

  • Select the artwork and click the Fill color or Stroke color in the Properties panel. With the Swatches option selected, click the pattern swatch to apply it.

Edit the pattern

  • In order to edit the pattern, with the artwork selected, click either the Fill color or Stroke color in the Properties panel (whichever you applied the pattern to), and with the swatches showing, double-click the pattern swatch to enter Pattern Editing mode.

Did this answer your question?